Search This Blog

Tuesday, November 3, 2009

Allow not compatible extensions in Firefox

The last version of firefox is out, but an extension that I use daily (QuickProxy) has not been updated yet. In fact, it should work but it is considered ‘not compatible’ by firefox and thus, is automatically de-activated.

The workaround (at your own risks !) is to bypass the security that enforces the compatibilty of extensions.

  • Open firefox and enter  “about:config” in the URL bar.
  • Right click in the page, then “new->boolean”
  • enter “extensions.checkUpdateSecurity” as the preference name in the dialog
  • set it’s value to false.
  • Create a similar entry called “extensions.checkCompatibility” set to false too.

Be careful when testing unsupported extensions, you may want to activate them one by one ! However do not hesitate to try, I have been able to succesfully use QuickProxy this way for more than a month….

For the record, the list of all the about:config options of firefox.

Ref : http://demeringo.ovh.org/blog/



No comments: